Ruby Sass is deprecated and will be unmaintained as of 26 March 2019

未分類

以前 rails で
「Ruby Sass is deprecated and will be unmaintained as of 26 March 2019」というメッセージが出ていて

sass-rails から sassc-rails に移行した人も多いと思います。

しかし、
sass-rails 6.0.0 から sassc-rails のラッパーとなったようです。
https://github.com/rails/sass-rails/releases/tag/v6.0.0

つまり、sass-rails 6.0.0 からは、 内部的には sassc-rails と同等なので、無理して sassc-rails に移行する必要はなく、sass-railsのままでよい、ということですね!

頑張って移行した人は、無駄な努力だったかもしれませんが、こっちの方がいいですね。

タイトルとURLをコピーしました